Waiting for receipt acknowledgement (EERP/NERP)

You are here

Waiting for receipt acknowledgement (EERP/NERP)

8 posts / 0 new
Last post
phernas
phernas's picture
Waiting for receipt acknowledgement (EERP/NERP)

Hi all,

I have a problem sending messages to a partner.
He receives the messages, but I dont get the EERP. And the status is:
Waiting for receipt acknowledgement (EERP/NERP)
After that it changes to Wait time for message receipt acknowledgement exceeded

Is there an option to set something like an "sync" EERP?

Best regards
Patrick

service
service's picture

phernas,

this is not possible in OFTP2. Main reason is the routing capability (different SFID and SSID) which means that your current session partner is not the transmission partner - there a sync "answer" could never be accomplished. OFTP2 is not based on HTTP/s - there is no backchannel like in AS2 or AS4 (push) - where the data postprocessing is done while the connection is still open (that is the reason why sync answer in AS2/AS4 is not a good selection in production use as it uses a lot of resources). The OFTP2 protocol is designed better as AS2/AS4 in this case as it uses less resources because the postprocessing and preprocessing of the data is completly independent from the transmission phase.
It might happen that you receive the EERP/NERP in the same session but this is random and depends on how fast your partner system creates the EERP which works after the inbound data has been postprocessed (decrypt, signature verification).
Another point - you will not receive a EERP if your partner could not reach you (firewall, whitelist etc)! In this case you could add a poll to ask your partner for available data (EERP/NERP) using a time interval.

Regards

phernas
phernas's picture

Hi service,

thank you for your help.
Tried to set the connection to "connect partner even if no outbound data is available". "Poll all 15 minute(s)"

But got the following error:
[Jul 5, 2016 11:58:41 AM] Initializing outgoing connection to Partner [xxxx.xxxxx.com/xx.xxx.xxx.xxx:6619] (TLS)
[Jul 5, 2016 11:58:41 AM] [Session 146771272138597] Connection established [xxxx.xxxxx.com/xx.xxx.xxx.xxx:6619]
[Jul 5, 2016 11:59:01 AM] [Session 146771272138597] The remote partner has been identified as Partner(XXXXX SSID)
[Jul 5, 2016 11:59:01 AM] [Session 146771272138597] Received unreferenced EERP [

[Jul 5, 2016 11:58:41 AM] [Session 146771272138597] Connection established [xxxx.xxxxx.comm/xx.xxx.xxx.xxx:6619]
[Jul 5, 2016 11:59:01 AM] [Session 146771272138597] The remote partner has been identified as Customer(O000XXXXXXXXXXXXXXXXX)
[Jul 5, 2016 11:59:01 AM] [Session 146771272138597] Received unreferenced EERP [ - O01770000000000XXXXXXXXXX][VFN.VDA4905 20160705 1137300034], ignoring
[Jul 5, 2016 11:59:01 AM] [Session 146771272138597] Session terminated [Customer - Partner] ("Normal session termination", internal code 0)
[Jul 5, 2016 11:59:01 AM] [Session 146771272138597] Connection closed [Customer - Partner, xxxx.xxxxx.com/xx.xxx.xxx.xxx:6619]. Established for 20.0s, 11907 bytes transfered

Any idea?

service
service's picture

phernas,

works fine.

phernas wrote:

[Jul 5, 2016 11:59:01 AM] [Session 146771272138597] Received unreferenced EERP
Any idea?

Every transaction in OFTP2 is identified by the three values virtual filedate, virtual filetime and virtual filename.

If these values of an inbound EERP are not available in your system (in combination) as transaction this message occurs. Have you deleted your outbound transaction meanwhile?

Regards

phernas
phernas's picture

No, the messages was yellow in the log above
In the meantime it changed to "Wait time for message receipt acknowledgement exceeded".

Thats the transmission and acknowledgement log:
Transmission
[Jul 4, 2016 9:34:32 AM] [Session 146761766024879] Outbound transmission started [ CustomerMain - RemotePartner | CustomerStation (O01770000000000X0XXXXXXXXX) - Customer(O00020000050XXXXXXXXXXX) ]
[Jul 4, 2016 9:34:33 AM] [Session 146761766024879] Data fully transmitted. Sent 1536 bytes in 0.8s (2.0 kb/s)
[Jul 4, 2016 9:34:33 AM] [Session 146761766024879] Waiting for receipt acknowledgement (EERP/NERP)

Acknowledgement
[Jul 4, 2016 10:34:57 AM] The transmission VFN.VDA4905 [VFN.VDA4905|20160704|0932560028] is pending for more than 1 h and has been stopped.

Best regards

phernas
phernas's picture

I have an update about a working eerp and the non working eerp:

Working from another partner with pickup shedule: (3 times the same virtualfilename/filedate/virtualfiletime)

Starting data preprocessing: VFN201607131546590008
Moved preprocessed data to: pending\VFN201607131546590008
Receipt acknowledgement (EERP) received [RemotePartner - CustomerStation]
Outbound transfer file deleted [VFN201607131546590008]

Nonworking partner with pickup shedule:
(2 times the same virtualfilename/filedate/virtualfiletime and 1 time blanks between these values)

Starting data preprocessing VFN201607121231380003
Moved preprocessed data to: pending\VFN201607121231380003
Received unreferenced EERP: VFN4905 20160712 1231380003

It seems that there are blanks between the three values in the eerp

Best regards

service
service's picture

phernas,

these are just the log settings. To see what really has been transmitted please enable the protocol message log and see what your partner transmitted - perhaps he transmitted blanks in the virtual filedate or something like that. These values are in the protocol message "SFID" (start file id)

Regards

phernas
phernas's picture

Dear service,

I have turned on the protocol message log and found two differences between this partner and other partners:

1. Other partners are sending the EERPDEST with the SFID I have used to send to this partner. This partner is sending our Mainstation SSID
2. EERPORIG is empty

| 56 | X(25) | EERPDEST | Destination | 'O01770000000000X0XXXXXXXXX' |
| 81 | X(25) | EERPORIG | Originator | ' ' |

Just for your info:
This partner is unsing WebEdiTrust / ICDSC